カテゴリー: ネットワーク

本日の動画 Windows10のIPアドレスを瞬時に変更する方法

Windows 10のIPアドレスを素早く簡単に変更する方法をご紹介します。

一般的には、ネットワークのプロパティを開いてアドレスを入力する必要がありますが、あらかじめ、バッチファイル(batファイル)を作っておけば、
右クリックして実行するだけで簡単にIPアドレスの変更ができます。
ネットワーク関連の仕事をしている人は、作業効率を格段に上げることができますので、ご活用ください。

IPoEでのネットワークカメラへの外部からのアクセス(静的IPマスカレード機能)

さて、前回は、IPoEとPPPoEを併用した場合の外部からの
ネットワークカメラへのアクセスの設定例をご案内したが、今回は
PPPoEの接続なしに、IPoEプランだけで外部からアクセスする例を
ご紹介したと思う。構成例は以下のようになる。

IPoEプランでは、基本的にIPv4のグローバルIPアドレスは、アドレスシェアしていて、複数の契約者が共有して使っている。
そのためIPv4 over IPv6のMAP-E方式で使えるポート番号は限られている。

なので、まず使えるポート番号がないかを調べる必要がある。
ヤマハルータで以下のコマンドを入力すると
show nat descriptor address
使用できるポート番号を確認できる。以下実行例

外側アドレス map-e というところに表示されているIPアドレスが
グローバルIPv4アドレスということになる。
そして、ポート範囲と書かれているところが使えるポート番号の一覧ということになる。

このなかから、ネットワークカメラへのアクセスのためのポート番号を
選び静的IPマスカレード設定を行う。
例えば、ポート番号61296を使用するとする。

外部からのアクセスは、IPv4のグローバルIPアドレス(114.xxx.xxx.9)
ポート番号61296をめがけてやってくる。
それを内部のネットワークカメラのアドレスとポートに転送する
設定をしてあげれば良いことになる。

114.xxx.xxx.9:61296→192.168.10.100:80

ポイントになる設定を以下に抜粋します。
#MAP-Eのトンネルにフィルタを適用
tunnel select 1
tunnel encapsulation map-e
tunnel map-e type ocn
ip tunnel mtu 1460
ip tunnel secure filter in 300030 400100 300039

#フィルター設定
ip filter 300030 pass * 192.168.10.0/24 icmp * *
ip filter 300039 reject * *
ip filter 400100 pass * 192.168.10.100 tcp * www

#nat設定
nat descriptor masquerade static 1200 1 192.168.10.100 tcp 61296=www

フィルタの適用順番には意味があるので注意が必要です。
ip tunnel secure filter in 300030 400100 300039

ip tunnel secure filter in 300030 300039 400100
となると、アクセスがうまく行かない。
どうも前から順番に処理されるようで、フィルタ番号300039
は、すべてをreject(拒否する)という設定のため、先にその処理が
されてしまうとアクセスが拒否されてしまう。

設定手順を動画にしました。設定のほとんどは、WebGUIでやっています。

IPoEとPPPoEの併用。ネットワークカメラへの外部からのアクセス(静的IPマスカレード機能)

IPoEプランでは、IPv4のグローバルIPアドレスは、複数の契約者で
共有しているので、OCNなどで利用されるMAP-E方式では、利用できるポート番号に制限がある。そのため、PPPoEと併用することで、ポート番号の制限を
気にせず設定可能となる。

上記のようなネットワーク構成例で、具体的な設定を考えていってみよう。

IPoEやPPPoE、そしてネットボランチDNSの設定などについては、
別のブログに書いているので、そちらを参考にしてほしい。
そこまで設定できているとして、外部からのアクセスをネットワークカメラに
転送(ポートフォワーディング)する設定を紹介したい。

ポートフォワーディングの設定とは、いわゆる静的IPマスカレード設定となる。
ポイントとしては、詳細設定のNAT設定より設定を行うが、
IPoEのNAT設定ではなく、PPPoE側のNAT設定を選んで設定する。

静的IPマスカレード設定にて、内側アドレスをネットワークカメラのIPアドレスにし、ポート番号は、カメラにアクセスするときに使用するポート番号を入力する。

通常は、これで準備完了だが、IPoEと併用しているため、
ここでもまた、フィルタ型ルーティングの設定が必要となる。
リモートアクセスVPNや拠点間VPNの時は、
プロトコルによって接続先を変える設定にしたが、
今回は、ホストによって接続先を変えるという設定を行う。

ネットワークカメラのIPアドレスが192.168.10.100として、
以下のような設定となる。

ip filter 500020 pass 192.168.10.100 * tcp * *
ip route default gateway tunnel 1 gateway pp 1 filter 500020


ヤマハネットワークエンジニアドリル全問正解!

ヤマハネットワークエンジニア会というサイトがあるが、

そこで、ヤマハルータやネットワークについての

問題が375問出題されている。

確か半年くらい前から、少しずつこなしていったが、

1月末に、とうとう375問全問正解することができた。

順位は1位。

1位と言っても、全問正解者は

自分を含めて15人くらいいるのだが。

問題をやりながら、ヤマハルータに関する新しい

知識も得られたりもするので、隙間時間などに

挑戦してみても良いかもしれない。

ヤマハルーター DHCPで除外IPアドレス設定

ヤマハルーターのDHCPサーバ機能を使って、

ネットワークにIPアドレスを配布しているケースは結構あると思います。

例えば、ヤマハルータ自体のIPアドレスが192.168.100.1だとして

DHCPで配布するIPアドレスの範囲を

192.168.100.2~192.168.100.100

にするなどできる。

ネットワークプリンタやNASなど、IPアドレスを固定で設定しておいた方が

都合が良いケースがあるが、管理が行き届いていないと

いつの間にかDHCP配布IPアドレスの範囲のIPアドレスが設定されている

場合がある。

その場合、DHCPで配布されパソコンに設定されたIPアドレスが、

ネットワークプリンタと重複してしまう可能性がある。

IPアドレスの重複は、トラブルの原因になりうるので、避けたい。

そんな場合、固定IPアドレスで使っているアドレスを

DHCPの範囲から除外する設定方法がある。

以下、設定例 except以下に除外アドレスを指定する。

dhcp scope 1 192.168.100.2-192.168.100.10/24 except 192.168.100.5

除外するIPアドレスが複数ある場合は、スペースを空けて並べていく。

以下、設定例

<前方は省略> except 192.168.100.5 192.168.100.8

範囲指定も可能だ。設定例

<前方は省略> except 192.168.100.5-192.168.100.8

以下に、実際の設定手順を動画にしたので、ご参照ください。

新PLCアダプタ導入 1階と2階を有線でつなげる

ある日、自宅の内線電話がうまく使えなくなり、アマゾン FireStickでの動画
見れなくなった。

自宅のネットワーク構成は、言葉で説明しても、なかなか難しいと思うので、
図を作成しました。

Amazon Fire Stickを試しに、1Fの無線ルータに接続すると
動画が動作したので、根本的にインターネットの接続に問題があるわけではない。
そもそも内線電話の使用は、インターネットに接続しているかどうかに関係ない。

2階の無線ルータを1階に持っていき、NVR500の下部につなげると
使える。結局、PLCアダプタが問題だったようだ。
PLCアダプタは、LAN配線が難しい場所を、屋内電気配線を使って
LAN接続する装置だ。

私の自宅の場合、PLCアダプタを1階と2階のコンセント差込口に、差して
1階と2階を接続している。

壊れてしまったものは仕方がないので新しいPLCアダプタを購入することにした。
アマゾンのレビューなどを参考に、TP-Link PLCアダプター TL-PA4010 KIT
を購入。既存のPLCアダプタと入れ替えたところ、無事、内線電話が
復活した。

日経新聞 「日本の光通信速度、23位に転落」について

2月16日(土)の日経新聞の記事に、

「日本の光通信速度、23位に転落」という記事が掲載された。

記事には、ボトルネックは、NTT東西の接続装置だ。とある。

この接続装置とは、いわゆるPPPoE接続のための装置だ。

この部分の設備増強は、ネット接続事業者(プロバイダ)の申請により

NTTが利用状況をみて行われる。

つまりプロバイダが自由に設備を増強できないので、

回りくどいことになっていると言える。

最近はやりのIPoE IPv6接続によるインターネット接続は、

ボトルネックとなっている接続装置を経由せずに、

インターネットにアクセスできるので、

結果、遅延が起こりづらい。

IPoE接続の場合のインターネット接続部分の設備は、

VNE事業者といわれる企業が、自身の判断で増強できる。

ほとんどプロバイダで、IPoE IPv6の接続サービスを

提供可能となってきているが、多くの場合、

VNE事業者の2次提供をしている。

例えばIIJであれば、VNEとしてインターネットマルチフィード株式会社

を利用している。

Ciscoルータを使ってVPNワイド疑似環境の作成

さて2週間くらい前の記事で、Ciscoルータを使って

PPPoEサーバを構築したことを書いた。

そこで、今回は、Ciscoルータを使って

フレッツVPNワイドの疑似環境を作ることを記事にしたいと思う。

というのも、VPNワイドは、PPPoEの接続をして拠点間通信を実現する

ものなので、CiscoルータにNTTの網側のPPPoE認証部分の役割をしてもらい

Ciscoルータ下部に、各拠点に設置する想定のルータを接続する。

以前のブログにも書いたが、VPNワイドは初期値で

以下のユーザIDと払い出しIPアドレスが設定されている。

この辺に関しては、右側のカテゴリからVPNワイドを選んで

他の記事を確認してほしい。

user01 192.168.100.1/32

user02 192.168.100.2/32

user03 192.168.100.3/32

(以下省略)

そして、契約時に企業識別子という情報が発行される。

企業識別子が仮に、cvn1234567890

だとすると、ルータに設定するPPPoEの

ユーザIDとパスワードは、user01の場合

接続ID user01@cvn1234567890

接続パスワード user01

となる。

そのことを踏まえて、Ciscoルータでの設定は、以下のようになる。

username user01@cvn1234567890 password 0 user01
username user02@cvn1234567890 password 0 user02

bba-group pppoe pppoe01
virtual-template 1

bba-group pppoe pppoe02
virtual-template 2

interface FastEthernet0
switchport access vlan 1
no ip address

interface FastEthernet1
switchport access vlan 2
no ip address

interface Virtual-Template1
mtu 1454
ip address 10.128.1.2 255.255.255.0
peer default ip address pool pool01
ppp authentication chap

interface Virtual-Template2
mtu 1454
ip address 10.128.1.2 255.255.255.0
peer default ip address pool pool02
ppp authentication chap

interface Vlan1
no ip address
pppoe enable group pppoe01

interface Vlan2
no ip address
pppoe enable group pppoe02

ip local pool pool01 192.168.100.1
ip local pool pool02 192.168.100.2

ネットワーク構成図の右側のヤマハルータの設定例は、

以下のようになる。

ip route default gateway pp 1
ip route 192.168.10.0/24 gateway tunnel 1
ip lan1 address 192.168.20.1/24
pp select 1
pp always-on on
pppoe use lan2
pppoe auto disconnect off
pp auth accept chap
pp auth myname user02@cvn1234567890 user02
ppp lcp mru on 1454
ppp ipcp ipaddress on
ppp ipcp msext on
ppp ccp type none
pp enable 1
tunnel select 1
ipsec tunnel 1
ipsec sa policy 1 1 esp aes-cbc sha-hmac
ipsec ike keepalive log 1 off
ipsec ike keepalive use 1 on
ipsec ike pre-shared-key 1 text yamaha
ipsec ike remote address 1 192.168.100.1
ip tunnel tcp mss limit auto
tunnel enable 1
ipsec use on
ipsec auto refresh on
syslog notice on
dhcp service server
dhcp server rfc2131 compliant except remain-silent
dhcp scope 1 192.168.20.2-192.168.20.191/24

このCiscoルータでの疑似環境で動作確認して、

想定通り動作するルータを、実際のVPNワイドを契約した

回線に接続すれば、理論上同じように動作するはずだ。

なので、Ciscoルータが手元にあるようなら、

本番環境でぶっつけ本番しなくとも事前に、

対抗拠点へのリモートデスクトップの動作確認などを

疑似環境で行える。

今回は、払い出しIPアドレスが、初期値の端末型払い出しの

設定例を紹介したが、LAN型払い出しの場合の

Ciscoルータの設定例もいつか紹介したいと思う。