イオン 優待 オーナーズカードの本領発揮!

私は、イオンの株主に、2年位前からなっているのだけど、

イオンの株主になるとオーナーズカードなるものをもらえる。

そのオーナーズカードの特典の一つは、イオン店内の

ラウンジなるスペースを利用できる。

そこに行くと、お菓子や飲み物がもらえて、

座って、その飲み物を飲んだりすることができる。

会社の近くに、イオンがありラウンジがある店舗なので、よく利用している。

喫茶店に入って、コーヒーを頼めば300円、400円かかると

思えば相当ありがたい。

ただし、ラウンジは、イオン全店舗にあるわけではない。

限られた店舗のみあるので、事前にチェックが必要だ。

ちなみに新潟県は、3店舗しかない。3店舗しかないのに、

会社の近くにあるのは相当ラッキーだ。

この前、他県に行ったときに、イオンに行ったのだが、

そのイオンは、イベント会場(ドーム)の最寄りだったため

イベントに参加する人たちでごった返していた。

フードコートは、人であふれかえり、席が足りていなかった。

そんななか、そのイオンには、ラウンジがあり、

オーナーズカードを使って、ラウンジ内に入り、

余裕で席の確保をし、コーヒーも無料でもらうことができ、

とても優越感を感じた。

しかも、このオーナーズカードは、イオンで買い物をした時に、

提示すると、あとからキャッシュバックがもらえる。

保有株数に応じて、パーセントが違うのだが、

100株なら3%だ。

例えば、20万円買い物したら、6000円キャッシュバックされる。

日常的に必要なものをイオンで購入するようにすれば、

その恩恵にあずかれる。

現在イオンの株価は、おおよそ2400円くらい。

100株を取得するのにい、24万円かかることになる。

銀行に、その24万円をあずけておいても、利子はほぼゼロに等しいが、

イオンの株に投資し、必要なものをイオンで購入するようにすれば、

キャッシュバックがもらえる。

イオンが利用できる人なら、相当お得のではないかなと思う。

また、イオンシネマも1000円で見ることができ、飲み物ももらえる。

お得が満載のイオン オーナーズカード、入手しておいて

損はないかもしれません。

ちなみに、オーナーズカードを入手するために、株を購入しておかなければ

ならない最終売買日は、2月25日(月)です。

無論、投資は自己責任でお願いしますね。


日経新聞 「日本の光通信速度、23位に転落」について

2月16日(土)の日経新聞の記事に、

「日本の光通信速度、23位に転落」という記事が掲載された。

記事には、ボトルネックは、NTT東西の接続装置だ。とある。

この接続装置とは、いわゆるPPPoE接続のための装置だ。

この部分の設備増強は、ネット接続事業者(プロバイダ)の申請により

NTTが利用状況をみて行われる。

つまりプロバイダが自由に設備を増強できないので、

回りくどいことになっていると言える。

最近はやりのIPoE IPv6接続によるインターネット接続は、

ボトルネックとなっている接続装置を経由せずに、

インターネットにアクセスできるので、

結果、遅延が起こりづらい。

IPoE接続の場合のインターネット接続部分の設備は、

VNE事業者といわれる企業が、自身の判断で増強できる。

ほとんどプロバイダで、IPoE IPv6の接続サービスを

提供可能となってきているが、多くの場合、

VNE事業者の2次提供をしている。

例えばIIJであれば、VNEとしてインターネットマルチフィード株式会社

を利用している。

幸楽苑 チョコレートラーメン食べてみた

最近、幸楽苑で、チョコレートラーメンなるものを食べてみた。

特に、ラーメンがチョコの味に悪影響を受けている感じはなかったが、

チョコを入れることで美味しくなっているかといえば、

そんな風には思えなかった。

また食べたいなと思わなかった。

普通に他のラーメン頼んだ方が良いかな。

映画マスカレードホテルを見てきた

2月10日土曜日に、木村拓哉、長澤まさみ主演の

映画マスカレードホテルを見てきた。

イオンの株主である私はイオンオーナーズカードを

使いイオンシネマで見たので、1000円で見れる。

映画は、なかなか面白かった。

東野圭吾作品だけあって、ストーリーが練られていて、

見ている人間の裏をかくようなところが随所にみてとれた。

一種間前に、「十二人の死にたい子どもたち」も見たが、

マスカレードホテルの方が、自分的には好きな作品だった。

マスカレードホテルの中で、少し引っかかった

内容があった。

容疑者のアリバイで、事件の起こった時刻に、容疑者の家に電話したら、

電話に出たということがアリバイとして説明されていたが、

NTTのサービスで、ボイスワープというものがあり、

設定しておくと、例えば携帯電話に転送できたりすので、

電話に出たから家にいたことがアリバイとなっていたのが、

少し設定の甘さを感じた。

素人が、まんまと騙されたということならよいが、

警察までも、そんなことを証拠として考えるわけはない。

作品の品質を上げるためには、専門家も交えるなどして

なにかしらよく知っている人がいたら、それは変だよ。

というのを無くしていくのも重要かなと思った。

Ciscoルータを使ってVPNワイド疑似環境の作成

さて2週間くらい前の記事で、Ciscoルータを使って

PPPoEサーバを構築したことを書いた。

そこで、今回は、Ciscoルータを使って

フレッツVPNワイドの疑似環境を作ることを記事にしたいと思う。

というのも、VPNワイドは、PPPoEの接続をして拠点間通信を実現する

ものなので、CiscoルータにNTTの網側のPPPoE認証部分の役割をしてもらい

Ciscoルータ下部に、各拠点に設置する想定のルータを接続する。

以前のブログにも書いたが、VPNワイドは初期値で

以下のユーザIDと払い出しIPアドレスが設定されている。

この辺に関しては、右側のカテゴリからVPNワイドを選んで

他の記事を確認してほしい。

user01 192.168.100.1/32

user02 192.168.100.2/32

user03 192.168.100.3/32

(以下省略)

そして、契約時に企業識別子という情報が発行される。

企業識別子が仮に、cvn1234567890

だとすると、ルータに設定するPPPoEの

ユーザIDとパスワードは、user01の場合

接続ID user01@cvn1234567890

接続パスワード user01

となる。

そのことを踏まえて、Ciscoルータでの設定は、以下のようになる。

username user01@cvn1234567890 password 0 user01
username user02@cvn1234567890 password 0 user02

bba-group pppoe pppoe01
virtual-template 1

bba-group pppoe pppoe02
virtual-template 2

interface FastEthernet0
switchport access vlan 1
no ip address

interface FastEthernet1
switchport access vlan 2
no ip address

interface Virtual-Template1
mtu 1454
ip address 10.128.1.2 255.255.255.0
peer default ip address pool pool01
ppp authentication chap

interface Virtual-Template2
mtu 1454
ip address 10.128.1.2 255.255.255.0
peer default ip address pool pool02
ppp authentication chap

interface Vlan1
no ip address
pppoe enable group pppoe01

interface Vlan2
no ip address
pppoe enable group pppoe02

ip local pool pool01 192.168.100.1
ip local pool pool02 192.168.100.2

ネットワーク構成図の右側のヤマハルータの設定例は、

以下のようになる。

ip route default gateway pp 1
ip route 192.168.10.0/24 gateway tunnel 1
ip lan1 address 192.168.20.1/24
pp select 1
pp always-on on
pppoe use lan2
pppoe auto disconnect off
pp auth accept chap
pp auth myname user02@cvn1234567890 user02
ppp lcp mru on 1454
ppp ipcp ipaddress on
ppp ipcp msext on
ppp ccp type none
pp enable 1
tunnel select 1
ipsec tunnel 1
ipsec sa policy 1 1 esp aes-cbc sha-hmac
ipsec ike keepalive log 1 off
ipsec ike keepalive use 1 on
ipsec ike pre-shared-key 1 text yamaha
ipsec ike remote address 1 192.168.100.1
ip tunnel tcp mss limit auto
tunnel enable 1
ipsec use on
ipsec auto refresh on
syslog notice on
dhcp service server
dhcp server rfc2131 compliant except remain-silent
dhcp scope 1 192.168.20.2-192.168.20.191/24

このCiscoルータでの疑似環境で動作確認して、

想定通り動作するルータを、実際のVPNワイドを契約した

回線に接続すれば、理論上同じように動作するはずだ。

なので、Ciscoルータが手元にあるようなら、

本番環境でぶっつけ本番しなくとも事前に、

対抗拠点へのリモートデスクトップの動作確認などを

疑似環境で行える。

今回は、払い出しIPアドレスが、初期値の端末型払い出しの

設定例を紹介したが、LAN型払い出しの場合の

Ciscoルータの設定例もいつか紹介したいと思う。


PowerPointで使えるヤマハのアイコンが超便利!

最近、ヤマハのサイトでヤマハルータのアイコン(図)を見つけた。

自由に使って良いらしい。リンクは下記

https://network.yamaha.com/support/download/tool

RTX1210やNVR510などのルータのアイコンはもちろん

電話機やスマホなど、

その他さまざまなアイコンがある。

例えば、お茶やATMまであるのだ。

PowerPointで構成図等を作るときなど、結構使えそう!

Cisco PPPoEサーバ動作しました。

2018年11月に書いた記事で、Cisco PPPoEサーバがうまく動作しない。

という内容を投稿しましたが、動作確認できました。

結局、ヤフオクで、別のCisco 892を入手して、

設定を試したところ無事動作しました。

やっぱり、ファームウェアのバージョンの差としか思えない。

動作確認後、同じ設定を、前に設定を試みた

cisco 892に設定したがやっぱり動かない。

今回、PPPoEサーバの動作を確認できたCiscoのIOSのバージョンは、

Version 15.2(4)M5 です。

他の方が設定例をアップしてくれた記事に書いてあったバージョンより

新しいバージョンを選んでヤフオクでは落札しました。

ciscoは保守契約的なことをしないとファームウェアをダウンロードできない

のでやっかいですね。

動いて当然のものが動かないのだから、保守契約関係なくダウンロード

できるようにほしいものです。

そう考えると、ヤマハは良心的です。

昨年、13年前の機種であるRT57iのファームウェアのアップデートも公開してくれました。

ヤマハ最高!

今回、試した構成図は、下記

Ciscoルータ892をPPPoEサーバとして、ヤマハルータ RTX1100 と RT107e

をPPPoEで接続しRTX1100とRT107eをIPsecでVPNトンネルを設定し

図のパソコンAから、RTX1100へ接続(telnet)できることを確認しました。

cisco 892の設定の抜粋

username test1@test.co.jp password 0 test1
username test2@test.co.jp password 0 test2

bba-group pppoe pppoe01
virtual-template 1

bba-group pppoe pppoe02
virtual-template 2

interface FastEthernet0
switchport access vlan 1
no ip address

interface FastEthernet1
switchport access vlan 2
no ip address

interface Virtual-Template1
mtu 1454
ip address 1.1.1.254 255.255.255.0
peer default ip address pool pool01
ppp authentication chap

interface Virtual-Template2
mtu 1454
ip address 2.2.2.254 255.255.255.0
peer default ip address pool pool02
ppp authentication chap

interface Vlan1
no ip address
pppoe enable group pppoe01

interface Vlan2
no ip address
pppoe enable group pppoe02

ip local pool pool01 1.1.1.1
ip local pool pool02 2.2.2.2

ヤマハルータの設定 RTX1100

ip route default gateway pp 1
ip route 192.168.2.0/24 gateway tunnel 1
ip lan1 address 192.168.1.1/24
pp select 1
pp always-on on
pppoe use lan2
pppoe auto disconnect off
pp auth accept chap
pp auth myname test1@test.co.jp test1
ppp lcp mru on 1454
ppp ipcp ipaddress on
ppp ipcp msext on
ppp ccp type none
pp enable 1
tunnel select 1
ipsec tunnel 1
ipsec sa policy 1 1 esp aes-cbc sha-hmac
ipsec ike keepalive log 1 off
ipsec ike keepalive use 1 on
ipsec ike pre-shared-key 1 text yamaha
ipsec ike remote address 1 2.2.2.2
ip tunnel tcp mss limit auto
tunnel enable 1
ipsec use on
ipsec auto refresh on
syslog notice on
dhcp service server
dhcp server rfc2131 compliant except remain-silent
dhcp scope 1 192.168.1.2-192.168.1.191/24

ヤマハルータの設定 RT107e

ip route default gateway pp 1
ip route 192.168.1.0/24 gateway tunnel 1
ip lan1 address 192.168.2.1/24
pp select 1
pp always-on on
pppoe use lan2
pppoe auto disconnect off
pp auth accept chap
pp auth myname test2@test.co.jp test2
ppp lcp mru on 1454
ppp ipcp ipaddress on
ppp ipcp msext on
ppp ccp type none
pp enable 1
tunnel select 1
ipsec tunnel 1
ipsec sa policy 1 1 esp aes-cbc sha-hmac
ipsec ike keepalive log 1 off
ipsec ike keepalive use 1 on
ipsec ike pre-shared-key 1 text yamaha
ipsec ike remote address 1 1.1.1.1
ip tunnel tcp mss limit auto
tunnel enable 1
ipsec use on
ipsec auto refresh on
syslog notice on
dhcp service server
dhcp server rfc2131 compliant except remain-silent
dhcp scope 1 192.168.2.2-192.168.2.191/24

これで、フレッツVPNワイドの疑似環境も作れそうです。

株は買ったら忘れてしまえ!

「米国株」高配当投資という本を参考に、

2019年は米国株に投資を始めようと思っている。

そこで、数年ぶりに、楽天証券のネット口座にログインしてみた。

すっかり忘れていたのだけど、リソー教育(4714)を

2007年11月に1株買っていた。

とりあえずの取引実績を作るために、株価が安かったので

適当に買った株だったが、株式分割などがあったらしく

30株となっていて、評価額が3倍くらいになっていた。

株は買ったら忘れてしまえ!という格言的なものがあったかと思うが

まさに、このことか!という感じだった。

今まで、買った株が3倍になったことなどないので驚いた。

まあ、1株しか買っていなかったから、額的には大した儲けではない。

ヤマハルータでPPPoEパススルー

皆さん、あけましておめでとうございます。

2019年ですね。

さて、2018年にいつの間にか、ヤマハルータが

PPPoEパススルー機能が可能になっていました。

PPPoEパススルー機能とは、PPPoEの通信を素通しさせる機能です。

PPPoEブリッジ機能と呼ぶ場合もあります。

ヤマハルータで可能になったといっても、

NVR510やRTX1210など比較的新しい機種での話です。

また、ファームウェアのバージョンにも条件があります。

詳しくは、ヤマハのサイトを確認してください。

PPPoEパススルー機能が可能になったことで、上図のように

ヤマハルータ下部から、PPPoE接続が可能となります。

PPPoEパススルー機能がないと、下部からのPPPoE接続ができず、

ONUからスイッチなどで分岐させて、ルータを並列につなげ

などが必要になる場合もあります。

PPPoEパススルーのための具体的な設定は、


pppoe pass-through member lan1 lan2

これで、LAN側からWAN側へのPPPoEが素通しされる。

活用例として、

サービス情報サイト(NGNv4)へのアクセスは、PPPoE接続が

必要だが、この設定をヤマハルータに行えば、

LAN側のパソコンからPPPoE接続を行うことができるようになる。