Cisco PPPoEサーバ動作しました。

2018年11月に書いた記事で、Cisco PPPoEサーバがうまく動作しない。

という内容を投稿しましたが、動作確認できました。

結局、ヤフオクで、別のCisco 892を入手して、

設定を試したところ無事動作しました。

やっぱり、ファームウェアのバージョンの差としか思えない。

動作確認後、同じ設定を、前に設定を試みた

cisco 892に設定したがやっぱり動かない。

今回、PPPoEサーバの動作を確認できたCiscoのIOSのバージョンは、

Version 15.2(4)M5 です。

他の方が設定例をアップしてくれた記事に書いてあったバージョンより

新しいバージョンを選んでヤフオクでは落札しました。

ciscoは保守契約的なことをしないとファームウェアをダウンロードできない

のでやっかいですね。

動いて当然のものが動かないのだから、保守契約関係なくダウンロード

できるようにほしいものです。

そう考えると、ヤマハは良心的です。

昨年、13年前の機種であるRT57iのファームウェアのアップデートも公開してくれました。

ヤマハ最高!

今回、試した構成図は、下記

Ciscoルータ892をPPPoEサーバとして、ヤマハルータ RTX1100 と RT107e

をPPPoEで接続しRTX1100とRT107eをIPsecでVPNトンネルを設定し

図のパソコンAから、RTX1100へ接続(telnet)できることを確認しました。

cisco 892の設定の抜粋

username test1@test.co.jp password 0 test1
username test2@test.co.jp password 0 test2

bba-group pppoe pppoe01
virtual-template 1

bba-group pppoe pppoe02
virtual-template 2

interface FastEthernet0
switchport access vlan 1
no ip address

interface FastEthernet1
switchport access vlan 2
no ip address

interface Virtual-Template1
mtu 1454
ip address 1.1.1.254 255.255.255.0
peer default ip address pool pool01
ppp authentication chap

interface Virtual-Template2
mtu 1454
ip address 2.2.2.254 255.255.255.0
peer default ip address pool pool02
ppp authentication chap

interface Vlan1
no ip address
pppoe enable group pppoe01

interface Vlan2
no ip address
pppoe enable group pppoe02

ip local pool pool01 1.1.1.1
ip local pool pool02 2.2.2.2

ヤマハルータの設定 RTX1100

ip route default gateway pp 1
ip route 192.168.2.0/24 gateway tunnel 1
ip lan1 address 192.168.1.1/24
pp select 1
pp always-on on
pppoe use lan2
pppoe auto disconnect off
pp auth accept chap
pp auth myname test1@test.co.jp test1
ppp lcp mru on 1454
ppp ipcp ipaddress on
ppp ipcp msext on
ppp ccp type none
pp enable 1
tunnel select 1
ipsec tunnel 1
ipsec sa policy 1 1 esp aes-cbc sha-hmac
ipsec ike keepalive log 1 off
ipsec ike keepalive use 1 on
ipsec ike pre-shared-key 1 text yamaha
ipsec ike remote address 1 2.2.2.2
ip tunnel tcp mss limit auto
tunnel enable 1
ipsec use on
ipsec auto refresh on
syslog notice on
dhcp service server
dhcp server rfc2131 compliant except remain-silent
dhcp scope 1 192.168.1.2-192.168.1.191/24

ヤマハルータの設定 RT107e

ip route default gateway pp 1
ip route 192.168.1.0/24 gateway tunnel 1
ip lan1 address 192.168.2.1/24
pp select 1
pp always-on on
pppoe use lan2
pppoe auto disconnect off
pp auth accept chap
pp auth myname test2@test.co.jp test2
ppp lcp mru on 1454
ppp ipcp ipaddress on
ppp ipcp msext on
ppp ccp type none
pp enable 1
tunnel select 1
ipsec tunnel 1
ipsec sa policy 1 1 esp aes-cbc sha-hmac
ipsec ike keepalive log 1 off
ipsec ike keepalive use 1 on
ipsec ike pre-shared-key 1 text yamaha
ipsec ike remote address 1 1.1.1.1
ip tunnel tcp mss limit auto
tunnel enable 1
ipsec use on
ipsec auto refresh on
syslog notice on
dhcp service server
dhcp server rfc2131 compliant except remain-silent
dhcp scope 1 192.168.2.2-192.168.2.191/24

これで、フレッツVPNワイドの疑似環境も作れそうです。

株は買ったら忘れてしまえ!

「米国株」高配当投資という本を参考に、

2019年は米国株に投資を始めようと思っている。

そこで、数年ぶりに、楽天証券のネット口座にログインしてみた。

すっかり忘れていたのだけど、リソー教育(4714)を

2007年11月に1株買っていた。

とりあえずの取引実績を作るために、株価が安かったので

適当に買った株だったが、株式分割などがあったらしく

30株となっていて、評価額が3倍くらいになっていた。

株は買ったら忘れてしまえ!という格言的なものがあったかと思うが

まさに、このことか!という感じだった。

今まで、買った株が3倍になったことなどないので驚いた。

まあ、1株しか買っていなかったから、額的には大した儲けではない。

ヤマハルータでPPPoEパススルー

皆さん、あけましておめでとうございます。

2019年ですね。

さて、2018年にいつの間にか、ヤマハルータが

PPPoEパススルー機能が可能になっていました。

PPPoEパススルー機能とは、PPPoEの通信を素通しさせる機能です。

PPPoEブリッジ機能と呼ぶ場合もあります。

ヤマハルータで可能になったといっても、

NVR510やRTX1210など比較的新しい機種での話です。

また、ファームウェアのバージョンにも条件があります。

詳しくは、ヤマハのサイトを確認してください。

PPPoEパススルー機能が可能になったことで、上図のように

ヤマハルータ下部から、PPPoE接続が可能となります。

PPPoEパススルー機能がないと、下部からのPPPoE接続ができず、

ONUからスイッチなどで分岐させて、ルータを並列につなげ

などが必要になる場合もあります。

PPPoEパススルーのための具体的な設定は、


pppoe pass-through member lan1 lan2

これで、LAN側からWAN側へのPPPoEが素通しされる。

活用例として、

サービス情報サイト(NGNv4)へのアクセスは、PPPoE接続が

必要だが、この設定をヤマハルータに行えば、

LAN側のパソコンからPPPoE接続を行うことができるようになる。

独学 プログラマー

さて、2018年もあとわずかになってしまいました。

毎年、1年早いな~と思いますが、今年は本当にとんでもなく

早かった。

今年は、3か月くらいしかなかったのではと思う。

2018年こそ、プログラムの基礎を身に着けようと思ったが、

すでに、残り一週間。

この目標は、来年度に持ち越されるわけだが、

初めの一歩だけでも進めておかなければと思い。

「独学プログラマー」という本を購入し、

この本にそって勉強することにした。

使う言語は、Python。

なので、さっそく、AWSのworkspaceに

https://www.python.org/

から、Pythonをダウンロードし、ダウンロードしたファイルを

ダブルクリックしインストールを試みると、

「このインストールはシステムポリシーで許可されていません。」

と表示され、インストールできない。

なんでじゃー?と戸惑ったが、なんのことはない。

ファイルを右クリックし、管理者として実行としたら、

無事インストールできた。

とりあえず、Hello World!と表示させてみた。

これで準備できたので、2019年こそプログラムの基礎を身につけるぞ!


東西間接続をするならVPNワイドよりVPNプライオが安くなる?!

NTT東日本とNTT西日本は、別会社のため

NTT東日本のフレッツVPNとNTT西日本のフレッツVPNを

接続したい場合、オプションの東西接続サービスを契約する必要がある。

東がVPNワイド、西もVPNワイドの場合、そのオプションの金額は

30,000円/月だ。東日本、西日本でそれぞれにこの金額がかかる。

※この金額はプランによって異なる。詳しくは下記を参照
https://business.ntt-east.co.jp/service/vpnwide/s_fee_ew.html

東がVPNプライオ、西がVPNワイドの場合、

東日本では、月に3,000円/1VPN拠点がかかる。

VPNワイドの場合の3万円に比べて、拠点数が多くなければ、

トータルコストが安くなる場合もある。

例えば、東日本のVPN拠点が3拠点の場合

VPNワイドの場合
1,800円×3拠点+30,000円=35,400円

VPNプライオの場合
7,000円×3拠点+3,000×3拠点=30,000円

となり、VPNプライオの方がコストが安い。

しかも、VPNプライオは、ルータのレンタル料金もこみの金額なので、

VPNワイドの場合、上記の金額にプラスルータのコストを

足さなければならない。

通信速度も、PPPoEを利用しないVPNプライオの方が

だいぶ速いので、その点も優位性がある。

そんなわけで、全国的に拠点があって、フレッツVPNの利用する場合、

ぜひ、VPNプライオにすることを検討してみてほしい。

ちなみに、西日本では、VPNプライオというサービスはなく、

東日本のVPNプライオと西日本のVPNワイドを接続することになる。


トラブル事例 VPN経由でWeb参照ができない。

少し前にブログで紹介したトラブル事例と似ているが、

VPN経由で、ネット参照ができないというトラブルの事例を紹介したい。

構成イメージは以下のようなる。

拠点側のPC01が、本社側を経由してインターネットへのアクセス

正確には、Web参照ができない。という現象が起こった。

そのPC01を、本社側に持っていき、LANに接続すると

Web参照できる。

PC01の拠点側でのネットワーク設定は、

デフォルトゲートウェイは、192.168.20.254

DNSサーバは、192.168.20.254 としてあった。

拠点のVPN用ルータ(NVR500)であるルータBには、

DNSサーバのアドレスとして、本社側のインターネット用ルータ(NVR510)

のIPアドレスである192.168.10.253が設定されていた。

そのため、PC01がWeb参照をしようとすると、DNSへの問い合わせは、

まず、192.168.10.254(ルータB)へいき、そのルータBを経由して

192.168.10.253へいく。

そこで、問題が生じていた。DNSの問い合わせをうけたNVR510には、

dns host lan1

という設定がされている。

これは、lan1に所属しているアドレスからしかDNSの問い合わせを

受け付けないという意味になる。

lan1とは今回の例でいうと、本社側のネットワークである

192.168.10.0/24のネットワークのことである。

拠点側は、192.168.20.0/24のネットワークのため

DNSの問い合わせが拒否され結果、名前解決ができず、

PC01はWeb参照ができなかった。ということになる。

この dns host lan1は、プロバイダへの接続設定であるPPPoEの

設定を行うと自動的に追加される。

NR510やRTX1210など、比較的最近の型番のヤマハルータで設定すると

気づかないうちに設定されている。

NVR500では、PPPoEの設定をしても、自動的に追加はされない。

今回の現象の対処方法としては、

dns host lan1を

dns host anyとすれば、拠点側のPC01からWeb参照ができるようになる。

anyの部分をIPアドレスの範囲の指定もできるようなので、

制限をしたい場合は、そのような設定をするのもありだろう。

今回の紹介したトラブル事例のように、各装置のそれぞれの設定は、

特に間違っているわけではないのだけど、全体としてうまく動作しない

ということがありうるのだ。

CiscoルータでPPPoEサーバが動作してくれない。。。

CiscoルータPPPoEサーバにして、

検証環境などで利用しようと考え、Cisco 892をヤフオクで

3000円程度で落札して設定を試みた。

CiscoルータをPPPoEサーバとして構築する

設定例は、ネットを検索すると、結構出てくるので、

それを参考に設定してみたが、

PPPoEクライアント側の接続を受け付けてくれない。

参考にさせていただいたのは、下記のサイトの情報。

YAMAHAルータとciscoルータのPPPoE接続

PPPoEクライアント側では、タイムアウトになってしまっているようだ。

Ciscoのログには、なにかしらPPPoE関連のログは出力されてこない。

IOSをアップデートすることで解決するのかな?!

Ciscoルータは、ファームウェアを気軽にダウンロードできなくて

厄介だ。

いろいろ、ネットで設定例を参考にしてやり直してみたが、

一向にうまくいかない。

試しに、同Ciscoルータで、外部へのPPPoE接続を試したがうまくいき、

ルータのLAN側に設置したパソコンから、Webサイトは参照できた。

そんなわけで根本的に壊れているとは考えづらい。

自分が購入したIOSのバージョンよりも新しいバージョンの

Ciscoルータをもう一台、ヤフオクで入手しようか検討中。

トラブル事例 ヤブ医者対応?!

今回は、VPN関連のトラブル事例をご紹介したい。

あるお客様から、営業担当者あてに、拠点のパソコンが、

VPNを経由して、本社側からインターネットへアクセス

できないから、本社のインターネット用ルータの設定を

変更してほしいという依頼があった。以下の図を参照してほしい。

営業担当者は、お客様の依頼どおり、本社側インターネットルータの設定変更

工事の手配をしようと準備していた。

って、ヤブ医者か?

まあ、営業だから仕方ない部分もあるが、お客様に言われたからと言って、

その通りやりますというのはプロとしていかがなものなのだろうか?

医者で言えば、患者から、

「先生、私胃が痛いから、胃潰瘍だと思うので、胃潰瘍の薬出してください。」

と言われて、「はい。わかりました。」と言って、胃潰瘍の薬処方するようなものだ。

医者なら、患者の症状を診断したうえで、どのような処置をするのかを

判断するのが当たり前だ。

結局、本件は、お客様の社内ネットワークでは、気軽にインターネットが参照

できないように、ルータにDNSの設定がされていなかった。

そのため、パソコンのDNSの設定を、そのパソコンが所属している

ネットワークのルータのIPアドレスにしても、ウェブサイトが参照できなかった

というわけだ。大体、他のパソコンで、ネットにアクセスできている

ものがあるのだから、インターネット接続用ルータで、

特定のIPアドレスのパソコンだけ、インターネットへの通信をブロックする設定

になっている可能性は低い。

ウェブサイトが見れなかったパソコンは、DNSの設定に

8.8.8.8を設定することで、ネット参照ができるよになった。

株主優待廃止!

株主優待目的で購入していた銘柄アクトコールが、

株主優待の廃止と無配を発表し、株価がダダ下がりしている。

昨日から成り行きで、売ろうと試みているが、

売れてくれない。

ダイヤモンドZAiという雑誌の株主優待特集の記事で、

見つけて、レストランのお食事券がもらえるということで、

購入したのだが、結果数万円損するはめになってしまった。

ただ、50株しか持っていないので、損する金額もたかが知れているのが

不幸中の幸いといえるだろう。

株を購入するとき、一回でほしい株数すべて買うのではなく、

分散して買うことにしている。

買って、いきなり大きく下げて大きな含み損になるリスクを小さくするためだ。

株主優待の銘柄は、株価が下がりにくいと言われているが、

優待廃止になるとひどいもんだね。。。

とりあえず、昨日今日と日経平均が反発しているから、

自分が保有している銘柄の株価がさらに上がって、

今回の暴落での損を取り戻してほしい。

株価の暴落!

先週 アメリカのダウ平均が大幅に暴落し、

それにともない10月11日(木)の日経平均も一時、一気に1000円超下落した。

私が保有している銘柄も、いくつかは損切されてしまった。

12日(金)も、大幅に下落するのではないかと恐れていたが、

日経平均は、少しだが反発して終わった。

このような株価の大暴落の対策として、

私は、オプション取引のプットに買いを入れている。

オプション取引とは、買う権利、売る権利を売買する取引のことだ。

買う権利をコールオプション、売る権利をプットオプションという。

非常にややこしいのだけど、例えば、2万円で売る権利を買っていて、

権利を執行できる日が来た時、株価が1万5千円になっていたら、

1万5千円を2万円で売ることができ、儲けることができる。

つまり、私は、このオプション取引を掛け捨て保険のように使っていて

暴落したときに、利益を出せるように、プットを買っている。

逆に暴騰した時に儲けるためには、コールオプションを買っておく必要がある。

今回の暴落時も、プットオプションの買いポジションを持っていたのだけど、

権利を行使できる日の二日前に暴落が起こったため、オプションの

売買価格が、大幅に高騰しなかった。仕方がないので、

数万円の利益で決済したが、タイミングがよければ、数十万儲かることもある。

権利を行使できる日をSQ日というのだけど、10月SQ日のオプションだけなく、

11月SQ日のプットオプションを持っていれば、大儲けできたと思う。

買おうとしていたのだけど、せこく指値で買おうとしたら、

買えずに失効してしまっていた。。。。

ちゃんと手堅く買っておけば良かった。

このような暴落は、必ずまた起こると思われるので、

今回の失敗を教訓に、次回の暴落時は、しっかり稼ぎたいと思う。